Categories

A sample text widget

Etiam pulvinar consectetur dolor sed malesuada. Ut convallis euismod dolor nec pretium. Nunc ut tristique massa.

Nam sodales mi vitae dolor ullamcorper et vulputate enim accumsan. Morbi orci magna, tincidunt vitae molestie nec, molestie at mi. Nulla nulla lorem, suscipit in posuere in, interdum non magna.

Tunnel IPIP between RouterOs and Linux

This is a small tutorial on how to establish an IPIP tunnel between a Linux Debian server and a Mikrotik RouterOs.

Linux Machine:

ip tunnel add tun0 mode ipip remote <remote_ip_address> local <local_ip_address>
ip link set tun0 up
ip addr add 192.168.200.1/24 dev tun0

Mikrotik RouterBoard:

/interface ipip add local-address=<local_address> remote-address=<remote_address>
/ip address add address=192.168.200.2/24 interface=ipip1

Check that there are no rules blocking protocol 4 and 94 input and output.

Try to ping the other end of the tunnel:

# ping 192.168.200.2
PING 192.168.200.2 (192.168.200.2) 56(84) bytes of data.
64 bytes from 192.168.200.2: icmp_req=1 ttl=64 time=84.1 ms

It works!

Leave a Reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

  

  

  

CAPTCHA

*